const regex = /REVIEWDOG_VERSION(?:\s*=\s*|:?\s*)[\"|\']?v?\K\d+\.\d+(\.\d+)?(-[^\'\"\s]*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('REVIEWDOG_VERSION(?:\\s*=\\s*|:?\\s*)[\\"|\\\']?v?\\K\\d+\\.\\d+(\\.\\d+)?(-[^\\\'\\"\\s]*)?', 'gm')
const str = `This is test file.
REVIEWDOG_VERSION=v0.1.0
REVIEWDOG_VERSION = v0.1.0
REVIEWDOG_VERSION=0.1.0
REVIEWDOG_VERSION = 0.1.0
REVIEWDOG_VERSION="v0.1.0"
REVIEWDOG_VERSION='v0.1.0'
REVIEWDOG_VERSION = "v0.1.0"
REVIEWDOG_VERSION = 'v0.1.0'
REVIEWDOG_VERSION="0.1.0"
REVIEWDOG_VERSION='0.1.0'
REVIEWDOG_VERSION = "0.1.0"
REVIEWDOG_VERSION = '0.1.0'
REVIEWDOG_VERSION="v0.1.0-nightly20201208+12faa31"
REVIEWDOG_VERSION='v0.1.0-nightly20201208+12faa31'
REVIEWDOG_VERSION = "v0.1.0-nightly20201208+12faa31"
REVIEWDOG_VERSION = 'v0.1.0-nightly20201208+12faa31'
REVIEWDOG_VERSION="0.1.0-nightly20201208+12faa31"
REVIEWDOG_VERSION='0.1.0-nightly20201208+12faa31'
REVIEWDOG_VERSION = "0.1.0-nightly20201208+12faa31"
REVIEWDOG_VERSION = '0.1.0-nightly20201208+12faa31'
ENV REVIEWDOG_VERSION=0.1.0
ENV REVIEWDOG_VERSION 0.1.0
ARG REVIEWDOG_VERSION=0.1.0
yaml:
REVIEWDOG_VERSION: 0.1.0
REVIEWDOG_VERSION: "0.1.0"
REVIEWDOG_VERSION: '0.1.0'
The above version should be updated to the latest version with this action.
Other test cases.
REDPEN_VERSION=1.10.1
TMUX_VERSION=3.0
`;
const subst = `1.0.0-nightly23423423423423523gdsg`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);