import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*<!\\[CDATA\\[00000:([\\w\\W]*?)\\]\\]>.*";
final String string = "String srcMsg=\"<?xml version=\\\"1.0\\\" encoding=\\\"UTF-8\\\"?>\\n<root><resultCode>00000</resultCode><resultDesc>\n"
+ "<![CDATA[00000:<ResponseClass Name=\\\"Response\\\">\\n <ResponseSubClass Name=\\\"attributesResponse\\\">\\n\n"
+ " <ITEM>0</ITEM>\\n </ResponseSubClass>\\n</ResponseClass>]]></resultDesc></root>\";\n"
+ "//The right code \n"
+ "java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(\".*<!\\\\[CDATA\\\\[00000:((.|\\n)*)\\\\]\\\\]>.*\"); \n"
+ "//wrong code1 \n"
+ "//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(\".*<!\\\\[CDATA\\\\[00000:(\\\\s|\\\\S)*\\\\]\\\\]>.*\");\n"
+ "//wrong code2 \n"
+ "//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(\".*<!\\\\[CDATA\\\\[00000:[\\\\w|\\\\W]*\\\\]\\\\]>.*\");\n"
+ "java\n\n\n"
+ "<![CDATA[00000: asdfasdf\n"
+ "sssdgasgf\n\n"
+ "asfgas\n"
+ "]]>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}