re = /.*<!\[CDATA\[00000:([\w\W]*?)\]\]>.*/
str = 'String srcMsg="<?xml version=\\"1.0\\" encoding=\\"UTF-8\\"?>\\n<root><resultCode>00000</resultCode><resultDesc>
<![CDATA[00000:<ResponseClass Name=\\"Response\\">\\n <ResponseSubClass Name=\\"attributesResponse\\">\\n
<ITEM>0</ITEM>\\n </ResponseSubClass>\\n</ResponseClass>]]></resultDesc></root>";
//The right code
java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(".*<!\\\\[CDATA\\\\[00000:((.|\\n)*)\\\\]\\\\]>.*");
//wrong code1
//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(".*<!\\\\[CDATA\\\\[00000:(\\\\s|\\\\S)*\\\\]\\\\]>.*");
//wrong code2
//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(".*<!\\\\[CDATA\\\\[00000:[\\\\w|\\\\W]*\\\\]\\\\]>.*");
java
<![CDATA[00000: asdfasdf
sssdgasgf
asfgas
]]>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end