$re = '/(?:^|,)([^\s,]+)(?:\s+[^\s,]+)*/m';
$str = 'hi,hello,sky,hi hello there';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);