package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{1,5})(\s*(\d{1,5}))*`)
var str = `213,345,123,456,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}