$re = '/(\d{1,5})(\s*(\d{1,5}))*/m';
$str = '213,345,123,456,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);