import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?=(\\d)\\d\\d([\\s\\-\\x{2013}\\x{2014}\\/]?))(?<![\\d\\-\\x{2013}\\x{2014}])(?!000|666|9\\d\\d|\\1{3}.?\\1{2}.?\\1{4}?|012.?34.?5678|123.?45.?6789|234.?56.?7890|098.?76.?5432|876.?54.?3210|078.?05.?1120|219.?09.?9999)\\d{3}\\2(?!00)\\d{2}\\2(?!0000)\\d{4}(?!\\d|[\\d\\-\\x{2013}\\x{2014}])(?!\\.(?:pdf|docx?|xlsx?|pptx?|zip|jpe?g|png|txt|log)\\b)";
final String string = "################\n"
+ "## Must match:\n"
+ "################\n\n"
+ "123-45-4891\n"
+ "098-18-6564\n"
+ "123-45-4848\n"
+ "702-02-0202\n"
+ "001-14-0004\n"
+ "009958881\n"
+ "009 95 8881\n"
+ "123-45-4891 is my ssn\n"
+ "my ssn is 123-45-4891\n"
+ "my ssn is 123-45-4891 ok?\n"
+ "my ssn is 123-45-4891.\n"
+ "123454891 is my ssn\n"
+ "my ssn is 123454891\n"
+ "my ssn is 123454891 ok?\n"
+ "my ssn is 123454891.\n"
+ "123 45 4891 is my ssn\n"
+ "my ssn is 123 45 4891\n"
+ "my ssn is 123 45 4891 ok?\n"
+ "my ssn is 123 45 4891.\n"
+ "my ssn is:123-45-4891.\n"
+ "my ssn is:123 45 4891.\n"
+ "my ssn is:123454891.\n"
+ "ss#123-45-4891\n"
+ "ssn123-45-4891\n"
+ "# Emdash separator:\n"
+ "123–45–4891\n"
+ "# Endash separator:\n"
+ "123—45—4891\n"
+ "# Slash separator\n"
+ "123/45/4891\n\n"
+ "################\n"
+ "## Must not match:\n"
+ "################\n\n"
+ "# Same number sequences:\n"
+ "222-22-2222\n"
+ "444 44 4444\n"
+ "555555555\n\n"
+ "# Ascending/Descending sequences:\n"
+ "123-45-6789\n"
+ "123 45 6789\n"
+ "123456789\n"
+ "876-543-21\n"
+ "876 543 21\n"
+ "87654321\n\n"
+ "# Known invalidated SSN:\n"
+ "219-09-9999\n"
+ "219099999\n"
+ "078-05-1120\n"
+ "078051120\n\n"
+ "# File names with common extensions:\n"
+ "123-45-4891.pdf\n"
+ "123-45-4891.xlsx\n"
+ "Check the attachment: 123-45-4891.xls, then get back to me.\n"
+ "Check the attachment: 123-45-4891.jpeg, then get back to me.\n\n"
+ "# Extra digits:\n"
+ "1-123-45-4891\n"
+ "123-45-4891-1\n"
+ "123-45-48911\n"
+ "1123-45-4891\n\n"
+ "# Mismatched separators:\n"
+ "123/45-4891\n"
+ "123-454891\n\n"
+ "# Telephone\n"
+ "1-234-567-8901\n"
+ "1-234-567-8901\n"
+ "1-234-567-8901 \n"
+ "1 (234) 567-8901\n"
+ "12347658901\n\n"
+ "# Credit card \n"
+ "5500 0000 0000 0004\n"
+ "3400 0000 0000 009\n"
+ "3000 0000 0000 04\n"
+ "5500-1244-2232-0004\n"
+ "3400-1244-0000-009\n"
+ "3000-1244-1234-04\n\n"
+ "# mixed (space), dash and (no space)\n"
+ "009 95-8881\n"
+ "009-95 8881\n"
+ "009 958881\n"
+ "00995 8881\n\n"
+ "# All-Zero group sequences\n"
+ "231-84-0000\n"
+ "231-00-7289\n"
+ "000-87-7289\n"
+ "231 84 0000\n"
+ "231 00 7289\n"
+ "000 87 7289\n"
+ "231840000\n"
+ "231007289\n"
+ "000877289\n\n"
+ "# Starting with 9\n"
+ "908-78-0485\n"
+ "908 78 0485\n"
+ "908780485\n\n"
+ "# Random Numbers\n"
+ "1234567890112371298739872891738912738937289d712897381297381927d3128937893d7218947d1892742189duc89789v127c897412987893c12893c79\n"
+ "122-426-389\n"
+ "187-5-43212\n"
+ "187-0-43212\n"
+ "2423-45-6789\n\n"
+ "# Unsupported boundaries:\n"
+ "ssn-123-45-4891\n"
+ "123-45-4891-ssn\n"
+ "# This one sneaks though, but we can live with that, maybe?\n"
+ "myssnnumberis123-45-4891ok?\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}