$re = '/(?i)(?=(\d)\d\d([\s\-\x{2013}\x{2014}\/]?))(?<![\d\-\x{2013}\x{2014}])(?!000|666|9\d\d|\1{3}.?\1{2}.?\1{4}?|012.?34.?5678|123.?45.?6789|234.?56.?7890|098.?76.?5432|876.?54.?3210|078.?05.?1120|219.?09.?9999)\d{3}\2(?!00)\d{2}\2(?!0000)\d{4}(?!\d|[\d\-\x{2013}\x{2014}])(?!\.(?:pdf|docx?|xlsx?|pptx?|zip|jpe?g|png|txt|log)\b)/m';
$str = '################
## Must match:
################
123-45-4891
098-18-6564
123-45-4848
702-02-0202
001-14-0004
009958881
009 95 8881
123-45-4891 is my ssn
my ssn is 123-45-4891
my ssn is 123-45-4891 ok?
my ssn is 123-45-4891.
123454891 is my ssn
my ssn is 123454891
my ssn is 123454891 ok?
my ssn is 123454891.
123 45 4891 is my ssn
my ssn is 123 45 4891
my ssn is 123 45 4891 ok?
my ssn is 123 45 4891.
my ssn is:123-45-4891.
my ssn is:123 45 4891.
my ssn is:123454891.
ss#123-45-4891
ssn123-45-4891
# Emdash separator:
123–45–4891
# Endash separator:
123—45—4891
# Slash separator
123/45/4891
################
## Must not match:
################
# Same number sequences:
222-22-2222
444 44 4444
555555555
# Ascending/Descending sequences:
123-45-6789
123 45 6789
123456789
876-543-21
876 543 21
87654321
# Known invalidated SSN:
219-09-9999
219099999
078-05-1120
078051120
# File names with common extensions:
123-45-4891.pdf
123-45-4891.xlsx
Check the attachment: 123-45-4891.xls, then get back to me.
Check the attachment: 123-45-4891.jpeg, then get back to me.
# Extra digits:
1-123-45-4891
123-45-4891-1
123-45-48911
1123-45-4891
# Mismatched separators:
123/45-4891
123-454891
# Telephone
1-234-567-8901
1-234-567-8901
1-234-567-8901
1 (234) 567-8901
12347658901
# Credit card
5500 0000 0000 0004
3400 0000 0000 009
3000 0000 0000 04
5500-1244-2232-0004
3400-1244-0000-009
3000-1244-1234-04
# mixed (space), dash and (no space)
009 95-8881
009-95 8881
009 958881
00995 8881
# All-Zero group sequences
231-84-0000
231-00-7289
000-87-7289
231 84 0000
231 00 7289
000 87 7289
231840000
231007289
000877289
# Starting with 9
908-78-0485
908 78 0485
908780485
# Random Numbers
1234567890112371298739872891738912738937289d712897381297381927d3128937893d7218947d1892742189duc89789v127c897412987893c12893c79
122-426-389
187-5-43212
187-0-43212
2423-45-6789
# Unsupported boundaries:
ssn-123-45-4891
123-45-4891-ssn
# This one sneaks though, but we can live with that, maybe?
myssnnumberis123-45-4891ok?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);