import re
regex = re.compile(r"(?<=,)\d+(?=%)")
test_str = ("Arthur Albert,74% \n"
"Melissa Hay,72%\n"
"William Jones,85%\n"
"Rachel Lee,68%\n"
"Joshua Planner,75%\n"
"Jennifer Ranger,76%")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")