use strict;
my $str = '%B4455000000660490^FARNSWORTH/SHANE ^24102010001090100001?
B4455000000660490^FARNSWORTH/SHANE ^24102010001090100001
as4455000000660490=24102010001090100001as
av8r;4455000000660490=24102010001090100001?67ab67
';
my $regex = qr/(\;?(3[0-9]{14}|[4-5][0-9]{15})=2[0-9](01|02|03|04|05|06|07|08|09|10|11|12)[1-2][0-6]{2}[a-zA-Z0-9 ]{7,13}\??)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}