using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^.]*\.\s*(?=.*\bcosts\b)(.*\bapple\b.*\.)$";
string input = @"Supermarket. This apple costs 0.99.
Supermarket. This costs apple 0.99.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}