re = /^[^.]*\.\s*(?=.*\bcosts\b)(.*\bapple\b.*\.)$/m
str = 'Supermarket. This apple costs 0.99.
Supermarket. This costs apple 0.99.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end