import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[[:^print:][:cntrl:]\\s]|GIF89.{0,20})*<\\?(?:php)?\\s*[[:punct:]\\s]+scama\\s*spotify\\s*v1[\\s\\#]+facebook:\\s*fb\\.com\\/amyr\\.gov\\.tn+[[:punct:]\\s]+.{0,200}?want\\s*to\\s*save\\s*rzlt\\s*.html(?:[^>]+>\\s*)?$";
final String string = "<?php \n"
+ "/*\n"
+ " $$$$$$\\ $$$$$$$\\ $$$$$$\\ $$\\ $$\\ $$$$$$$$\\ $$\\ $$\\ \n"
+ "$$ __$$\\ $$ __$$\\ $$ __$$\\ $$$\\ $$ | \\__$$ __|$$$\\ $$ |\n"
+ "$$ / $$ |$$ | $$ |$$ / $$ |$$$$\\ $$ | $$ | $$$$\\ $$ |\n"
+ "$$$$$$$$ |$$$$$$$ |$$ | $$ |$$ $$\\$$ |$$$$$$\\ $$ | $$ $$\\$$ |\n"
+ "$$ __$$ |$$ __$$< $$ | $$ |$$ \\$$$$ |\\______|$$ | $$ \\$$$$ |\n"
+ "$$ | $$ |$$ | $$ |$$ | $$ |$$ |\\$$$ | $$ | $$ |\\$$$ |\n"
+ "$$ | $$ |$$ | $$ | $$$$$$ |$$ | \\$$ | $$ | $$ | \\$$ |\n"
+ "\\__| \\__|\\__| \\__| \\______/ \\__| \\__| \\__| \\__| \\__|\n"
+ " \n"
+ "#==========================================#\n"
+ "# Scama Spotify v1 #\n"
+ "# facebook: fb.com/amyr.gov.tn #\n"
+ "#==========================================#\n\n"
+ " $$$$$$\\ $$$$$$\\ $$\\ $$$$$$\\ \n"
+ "$$ __$$\\ $$$ __$$\\ $$$$ | $$ __$$\\ \n"
+ "\\__/ $$ |$$$$\\ $$ |\\_$$ | $$ / $$ |\n"
+ " $$$$$$ |$$\\$$\\$$ | $$ | \\$$$$$$$ |\n"
+ "$$ ____/ $$ \\$$$$ | $$ | \\____$$ |\n"
+ "$$ | $$ |\\$$$ | $$ | $$\\ $$ |\n"
+ "$$$$$$$$\\ \\$$$$$$ /$$$$$$\\\\$$$$$$ |\n"
+ "\\________| \\______/ \\______|\\______/ \n"
+ "*/ \n"
+ "$aronxname = \"ARON-TN\";//<== Your Name \n"
+ "$aronxmail = \"moncompteperso12x0@gmail.com\"; //<== Your Email\n"
+ "$aronxsave = \"no\";//<== Write \"On\" if U want To Save RZlt .html !\n"
+ "?>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}