$re = '~\[\KA[^]]+~m';
$str = 'text [A1235] fdfdsf [B6548] fdfd
text [A771] fdfdsf [B6548] fdfd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);