re = /\[\KA[^]]+/m
str = 'text [A1235] fdfdsf [B6548] fdfd
text [A771] fdfdsf [B6548] fdfd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end