package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:\d+\.\d*)|(?:\d*\.?\d+))`)
var str = `xx123.456
xx123
xx.456
xx123.
xx.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}