$re = '/((?:\d+\.\d*)|(?:\d*\.?\d+))/m';
$str = 'xx123.456
xx123
xx.456
xx123.
xx.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);