import re
regex = re.compile(r"^(?:[1-9]|1[0-2]):[0-5][0-9]\s(?:[aApP](\.?)[mM]\1)?$")
test_str = "1:23 am"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")