using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/my-page\/(?!.*(?:foo|bar|baz)).+";
string input = @"/my-page/thing1
/my-page/another-thing
/my-page/foo
/my-page/bar
/my-page/baz
/my-page/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}