$re = '/^\/my-page\/(?!.*(?:foo|bar|baz)).+/m';
$str = '/my-page/thing1
/my-page/another-thing
/my-page/foo
/my-page/bar
/my-page/baz
/my-page/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);