import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(google([^\\/]+\\/){5}|microsoft([^\\/]+\\/){3}|cisco([^\\/]+\\/){2})(?<name>[^\\/]+)";
final String string = "RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/ronaldo/getbilledvspaid/v1\n"
+ "RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/ronaldo/paymenthistory/v1\n"
+ "RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/ronaldo/requesthistory/v1\n"
+ "RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/ronaldo/runninghistory/v1\n\n"
+ "RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/watson/invoicedetail/v1\n"
+ "RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/watson/invoicesummary/v1\n"
+ "RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/watson/gettingValue/v1\n"
+ "RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/watson/historyValue/v1\n\n"
+ "RuntimeException having https://microsoft.word.com/ringert/rkj3/obama/funatwork\n"
+ "RuntimeException having https://microsoft.word.com/ringert/rkj3/obama/runathome\n\n"
+ "RuntimeException having https://cisco-services.raj.com/ytr-services/gilchrist/vision\n"
+ "RuntimeException having https://cisco-services.raj.com/ytr-services/gilchrist/health";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}