# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https:\/\/(google([^\/]+\/){5}|microsoft([^\/]+\/){3}|cisco([^\/]+\/){2})(?<name>[^\/]+)"
test_str = ("RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/ronaldo/getbilledvspaid/v1\n"
"RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/ronaldo/paymenthistory/v1\n"
"RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/ronaldo/requesthistory/v1\n"
"RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/ronaldo/runninghistory/v1\n\n"
"RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/watson/invoicedetail/v1\n"
"RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/watson/invoicesummary/v1\n"
"RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/watson/gettingValue/v1\n"
"RuntimeException having https://google.yahoo.com/web/kiran/cart/groups/watson/historyValue/v1\n\n"
"RuntimeException having https://microsoft.word.com/ringert/rkj3/obama/funatwork\n"
"RuntimeException having https://microsoft.word.com/ringert/rkj3/obama/runathome\n\n"
"RuntimeException having https://cisco-services.raj.com/ytr-services/gilchrist/vision\n"
"RuntimeException having https://cisco-services.raj.com/ytr-services/gilchrist/health")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.