using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((\w*\s*),|\s*(\w*),|\s*(\w*)\)";
string input = @"Mon texte avant (terme1, terme2, terme3, term4, termeX) Mon texte après";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}