$re = '/\((\w*\s*),|\s*(\w*),|\s*(\w*)\)/im';
$str = 'Mon texte avant (terme1, terme2, terme3, term4, termeX) Mon texte après';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);