const regex = new RegExp('("{3}|["\\\\'])(?:(?=(\\\\?))\\2.)*?\\1', 'sg')
const str = `"""
Multi-line text 2 "'
"""
"String"
"12345"
'abcde'
'It\\'s'
"""Multi-line text"""`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}