$re = '/("{3}|["\'])(?:(?=(\\\\?))\2.)*?\1/s';
$str = '"""
Multi-line text 2 "\'
"""
"String"
"12345"
\'abcde\'
\'It\\\'s\'
"""Multi-line text"""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);