const regex = /time\(.*\)=(\d*(?:\.\d*)?)s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('time\\(.*\\)=(\\d*(?:\\.\\d*)?)s', 'gm')
const str = `    time(c:\\Program Files\\10.0\\2\\c1xx.exe)=0.23609s < 377648803844 - 377654889334 >
    time(c:\\Program Files\\10.0\\2\\c1xx.exe)=004421.s < 377648803844 - 377654889334 >
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}