#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(?:v(?:ersion)?-?)?\K\d+(?:\.\d+)+(?![^\/])"
Local $sString = "https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js > 1.11.2" & @CRLF & _
"https://ajax.googleapis.com/ajax/libs/jquery/v1.11.2/jquery.min.js > 1.11.2" & @CRLF & _
"https://ajax.googleapis.com/ajax/libs/jquery/version-1.11.2/jquery.min.js > 1.11.2" & @CRLF & _
"https://ajax.googleapis.com/ajax/libs/jquery/1-11-2/jquery.min.js > NULL" & @CRLF & _
"https://ajax.googleapis.com/ajax/libs/jquery/1112/jquery.min.js > NULL" & @CRLF & _
"https://www.google.com/recaptcha/api.js?render=6LdBsjgVaoTJ8rC-Npzz16bnAE > NULL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")