import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(?:v(?:ersion)?-?)?\\K\\d+(?:\\.\\d+)+(?![^\\/])";
final String string = "https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js > 1.11.2\n"
+ "https://ajax.googleapis.com/ajax/libs/jquery/v1.11.2/jquery.min.js > 1.11.2\n"
+ "https://ajax.googleapis.com/ajax/libs/jquery/version-1.11.2/jquery.min.js > 1.11.2\n"
+ "https://ajax.googleapis.com/ajax/libs/jquery/1-11-2/jquery.min.js > NULL\n"
+ "https://ajax.googleapis.com/ajax/libs/jquery/1112/jquery.min.js > NULL\n"
+ "https://www.google.com/recaptcha/api.js?render=6LdBsjgVaoTJ8rC-Npzz16bnAE > NULL";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}