const regex = /\(?\d{3}(\)|-)\d{3}-\d{4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(?\\d{3}(\\)|-)\\d{3}-\\d{4}', 'g')
const str = `605-867-5881
330-689-7373
267-809-9889
602-384-4536
215-482-7965
606-277-7608
615-270-6746
(410)806-1562
(614)226-8365
(609)571-6299
(410)719-9294
(678)916-4422
(202)874-4334`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}