# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\(?\d{3}(\)|-)\d{3}-\d{4}"
test_str = ("605-867-5881\n"
"330-689-7373\n"
"267-809-9889\n"
"602-384-4536\n"
"215-482-7965\n"
"606-277-7608\n"
"615-270-6746\n\n"
"(410)806-1562\n"
"(614)226-8365\n"
"(609)571-6299\n"
"(410)719-9294\n"
"(678)916-4422\n"
"(202)874-4334")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.