$re = '/^(.+)$/s';
$str = 'Hello this is a test string
and i want this to be accepted';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);