re = /^(.+)$/
str = 'Hello this is a test string
and i want this to be accepted'
# Print the match result
str.match(re) do |match|
puts match.to_s
end