#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a(?:.*\>)(.*)<\/a>"
Local $sString = "<a>I don't want this</a>" & @CRLF & _
"startString" & @CRLF & _
"test1" & @CRLF & _
"<a>I want this1</a>" & @CRLF & _
"test2" & @CRLF & _
"<a>I want this2</a>" & @CRLF & _
"endString" & @CRLF & _
"gibberish" & @CRLF & _
"<a>I don't want this</a>" & @CRLF & _
"startString" & @CRLF & _
"test1" & @CRLF & _
"<a>I want this3</a>" & @CRLF & _
"test2" & @CRLF & _
"<a>I want this4</a>" & @CRLF & _
"endString" & @CRLF & _
"gibberish" & @CRLF & _
"<a>I don't want this</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")