#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)^ # начало строки" & @CRLF & _
"(?:" & @CRLF & _
" ([a-z]) | # 1 гр" & @CRLF & _
" ([A-Z]) | # 2 гр" & @CRLF & _
" ([0-9]) # 3 гр" & @CRLF & _
")" & @CRLF & _
"(?(1) # если совпала 1 гр" & @CRLF & _
" [a-z]*+ # захватываем все символы как в 1 гр" & @CRLF & _
" (?:" & @CRLF & _
" ([A-Z]) | # 4 гр" & @CRLF & _
" ([0-9]) # 5 гр" & @CRLF & _
" )" & @CRLF & _
" (?(4) # если совпала 4 гр" & @CRLF & _
" [a-zA-Z]*+ # захватываем все символы как в 1 и 4 гр" & @CRLF & _
" [0-9]" & @CRLF & _
" [a-zA-Z0-9]*+" & @CRLF & _
" $ # закрыли весь поиск" & @CRLF & _
" | # иначе если совпала 4 гр" & @CRLF & _
" (?(5) # если совпала 5 гр" & @CRLF & _
" [a-z0-9]*+ #захватываем все символы как в 1 и 5 гр" & @CRLF & _
" [A-Z]" & @CRLF & _
" [a-zA-Z0-9]*+" & @CRLF & _
" $" & @CRLF & _
" | # иначе если совпала 5 гр" & @CRLF & _
" (?!) # роняем матчинг" & @CRLF & _
" ) # конец если совпала 5 гр" & @CRLF & _
" ) # конец если совпала 4 гр" & @CRLF & _
") # конец если совпала 1 гр" & @CRLF & _
"" & @CRLF & _
"(?(2) # если совпала 2 гр" & @CRLF & _
" [A-Z]*+ # захватываем все символы как в 2 гр" & @CRLF & _
" (?:" & @CRLF & _
" ([a-z]) | # 6 гр" & @CRLF & _
" ([0-9]) # 7 гр" & @CRLF & _
" )" & @CRLF & _
" (?(6) # если совпала 6 гр" & @CRLF & _
" [a-zA-Z]*+ # захватываем все символы как в 2 и 6 гр" & @CRLF & _
" [0-9]" & @CRLF & _
" [a-zA-Z0-9]*+" & @CRLF & _
" $ # закрыли весь поиск" & @CRLF & _
" | # иначе если совпала 6 гр" & @CRLF & _
" (?(7) # если совпала 7 гр" & @CRLF & _
" [A-Z0-9]*+ #захватываем все символы как в 2 и 7 гр" & @CRLF & _
" [a-z]" & @CRLF & _
" [a-zA-Z0-9]*+" & @CRLF & _
" $" & @CRLF & _
" | # иначе если совпала 7 гр" & @CRLF & _
" (?!) # роняем матчинг" & @CRLF & _
" ) # конец если совпала 7 гр" & @CRLF & _
" ) # конец если совпала 6 гр" & @CRLF & _
") # конец если совпала 2 гр" & @CRLF & _
"" & @CRLF & _
"(?(3) # если совпала 3 гр" & @CRLF & _
" [0-9]*+ # захватываем все символы как в 3 гр" & @CRLF & _
" (?:" & @CRLF & _
" ([A-Z]) | # 8 гр" & @CRLF & _
" ([a-z]) # 9 гр" & @CRLF & _
" )" & @CRLF & _
" (?(8) # если совпала 8 гр" & @CRLF & _
" [0-9A-Z]*+ # захватываем все символы как в 3 и 8 гр" & @CRLF & _
" [a-z]" & @CRLF & _
" [a-zA-Z0-9]*+" & @CRLF & _
" $ # закрыли весь поиск" & @CRLF & _
" | # иначе если совпала 8 гр" & @CRLF & _
" (?(9) # если совпала 9 гр" & @CRLF & _
" [0-9a-z]*+ #захватываем все символы как в 3 и 9 гр" & @CRLF & _
" [A-Z]" & @CRLF & _
" [a-zA-Z0-9]*+" & @CRLF & _
" $" & @CRLF & _
" | # иначе если совпала 5 гр" & @CRLF & _
" (?!) # роняем матчинг" & @CRLF & _
" ) # конец если совпала 5 гр" & @CRLF & _
" ) # конец если совпала 8 гр" & @CRLF & _
") # конец если совпала 3 гр"
Local $sString = "AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")