import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # начало строки\n"
+ "(?:\n"
+ " ([a-z]) | # 1 гр\n"
+ " ([A-Z]) | # 2 гр\n"
+ " ([0-9]) # 3 гр\n"
+ ")\n"
+ "(?(1) # если совпала 1 гр\n"
+ " [a-z]*+ # захватываем все символы как в 1 гр\n"
+ " (?:\n"
+ " ([A-Z]) | # 4 гр\n"
+ " ([0-9]) # 5 гр\n"
+ " )\n"
+ " (?(4) # если совпала 4 гр\n"
+ " [a-zA-Z]*+ # захватываем все символы как в 1 и 4 гр\n"
+ " [0-9]\n"
+ " [a-zA-Z0-9]*+\n"
+ " $ # закрыли весь поиск\n"
+ " | # иначе если совпала 4 гр\n"
+ " (?(5) # если совпала 5 гр\n"
+ " [a-z0-9]*+ #захватываем все символы как в 1 и 5 гр\n"
+ " [A-Z]\n"
+ " [a-zA-Z0-9]*+\n"
+ " $\n"
+ " | # иначе если совпала 5 гр\n"
+ " (?!) # роняем матчинг\n"
+ " ) # конец если совпала 5 гр\n"
+ " ) # конец если совпала 4 гр\n"
+ ") # конец если совпала 1 гр\n\n"
+ "(?(2) # если совпала 2 гр\n"
+ " [A-Z]*+ # захватываем все символы как в 2 гр\n"
+ " (?:\n"
+ " ([a-z]) | # 6 гр\n"
+ " ([0-9]) # 7 гр\n"
+ " )\n"
+ " (?(6) # если совпала 6 гр\n"
+ " [a-zA-Z]*+ # захватываем все символы как в 2 и 6 гр\n"
+ " [0-9]\n"
+ " [a-zA-Z0-9]*+\n"
+ " $ # закрыли весь поиск\n"
+ " | # иначе если совпала 6 гр\n"
+ " (?(7) # если совпала 7 гр\n"
+ " [A-Z0-9]*+ #захватываем все символы как в 2 и 7 гр\n"
+ " [a-z]\n"
+ " [a-zA-Z0-9]*+\n"
+ " $\n"
+ " | # иначе если совпала 7 гр\n"
+ " (?!) # роняем матчинг\n"
+ " ) # конец если совпала 7 гр\n"
+ " ) # конец если совпала 6 гр\n"
+ ") # конец если совпала 2 гр\n\n"
+ "(?(3) # если совпала 3 гр\n"
+ " [0-9]*+ # захватываем все символы как в 3 гр\n"
+ " (?:\n"
+ " ([A-Z]) | # 8 гр\n"
+ " ([a-z]) # 9 гр\n"
+ " )\n"
+ " (?(8) # если совпала 8 гр\n"
+ " [0-9A-Z]*+ # захватываем все символы как в 3 и 8 гр\n"
+ " [a-z]\n"
+ " [a-zA-Z0-9]*+\n"
+ " $ # закрыли весь поиск\n"
+ " | # иначе если совпала 8 гр\n"
+ " (?(9) # если совпала 9 гр\n"
+ " [0-9a-z]*+ #захватываем все символы как в 3 и 9 гр\n"
+ " [A-Z]\n"
+ " [a-zA-Z0-9]*+\n"
+ " $\n"
+ " | # иначе если совпала 5 гр\n"
+ " (?!) # роняем матчинг\n"
+ " ) # конец если совпала 5 гр\n"
+ " ) # конец если совпала 8 гр\n"
+ ") # конец если совпала 3 гр";
final String string = "AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8AaluhfDnaoufbicbIHBDIHBKJXNdCJKfBCNCNX5BCHBAHIBAVIsdniuhuygvD6w489bgtvdihfcbsigdbcsihcgfisyg8";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}