import re
regex = re.compile(r">[^<^\w]+<")
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
"<ORDRSP>\n"
" <UNH>\n"
" <E0062>MSG127</E0062>\n"
" <S009>\n"
" <E0065>ORDRSP</E0065>\n"
" <E0052>D</E0052>\n"
" <E0054>01B</E0054>\n"
" <E0051>UN</E0051>\n"
" <E0057>EAN010</E0057>\n"
" </S009>\n"
" </UNH>\n"
" <BGM>\n"
" <C002>\n"
" <E1001>231</E1001>\n"
" </C002>\n"
" <C106>\n"
" <E1004>ORSP12856</E1004>\n"
" </C106>\n"
" <E1225>4</E1225>\n"
" </BGM>\n"
" <DTM>\n"
" <C507>\n"
" <E2005>137</E2005>\n"
" <E2380>20041230</E2380>\n"
" <E2379>102</E2379>\n"
" </C507>\n"
" </DTM>\n"
" <DTM>\n"
" <C507>\n"
" <E2005>55</E2005>\n"
" <E2380>20041230</E2380>\n"
" <E2379>102</E2379>\n"
" </C507>\n"
" </DTM>\n"
" <FTX>\n"
" <E4451>TRA</E4451>\n"
" <C108>\n"
" <E4440>МАШ:3;30.06.2011,07:00-11:00,001;30.06.2011,17:30-18:00,001;29.06.2011,12:00-14:00,001;</E4440>\n"
" </C108>\n"
" </FTX>\n"
" <SG1>\n"
" <RFF>\n"
" <C506>\n"
" <E1153>ON</E1153>\n"
" <E1154>652744</E1154>\n"
" </C506>\n"
" </RFF>\n"
" <DTM>\n"
" <C507>\n"
" <E2005>171</E2005>\n"
" <E2380>20041229</E2380>\n"
" <E2379>102</E2379>\n"
" </C507>\n"
" </DTM>\n"
" </SG1>\n"
" <SG3>\n"
" <NAD>\n"
" <E3035>BY</E3035>\n"
" <C082>\n"
" <E3039>4607078289991</E3039>\n"
" <E3055>9</E3055>\n"
" </C082>\n"
" </NAD>\n"
" </SG3>\n"
" <SG3>\n"
" <NAD>\n"
" <E3035>SU</E3035>\n"
" <C082>\n"
" <E3039>4607077429992</E3039>\n"
" <E3055>9</E3055>\n"
" </C082>\n"
" </NAD>\n"
" </SG3>\n"
" <SG3>\n"
" <NAD>\n"
" <E3035>DP</E3035>\n"
" <C082>\n"
" <E3039>4606038009747</E3039>\n"
" <E3055>9</E3055>\n"
" </C082>\n"
" </NAD>\n"
" </SG3>\n"
" <SG26>\n"
" <LIN>\n"
" <E1082>1</E1082>\n"
" <E1229>3</E1229>\n"
" <C212>\n"
" <E7140>03312345501003</E7140>\n"
" <E7143>SRV</E7143>\n"
" </C212>\n"
" </LIN>\n"
" <PIA>\n"
" <E4347>1</E4347>\n"
" <C212>\n"
" <E7140>23543245634</E7140>\n"
" <E7143>SA</E7143>\n"
" </C212>\n"
" </PIA>\n"
" <PIA>\n"
" <E4347>1</E4347>\n"
" <C212>\n"
" <E7140>657867</E7140>\n"
" <E7143>IN</E7143>\n"
" </C212>\n"
" </PIA>\n"
" <QTY>\n"
" <C186>\n"
" <E6063>21</E6063>\n"
" <E6060>500</E6060>\n"
" </C186>\n"
" </QTY>\n"
" <QTY>\n"
" <C186>\n"
" <E6063>170</E6063>\n"
" <E6060>300</E6060>\n"
" </C186>\n"
" </QTY>\n"
" <SG30>\n"
" <PRI>\n"
" <C509>\n"
" <E5125>AAA</E5125>\n"
" <E5118>342.00</E5118>\n"
" </C509>\n"
" </PRI>\n"
" </SG30>\n"
" </SG26>\n"
" <UNS>\n"
" <E0081>S</E0081>\n"
" </UNS>\n"
" <CNT>\n"
" <C270>\n"
" <E6069>2</E6069>\n"
" <E6066>1</E6066>\n"
" </C270>\n"
" </CNT>\n"
" <UNT>\n"
" <E0074>15</E0074>\n"
" <E0062>MSG127</E0062>\n"
" </UNT>\n"
"</ORDRSP>\n")
subst = "><"
result = regex.sub(subst, test_str)
if result:
print(result)