$re = '/^https:\/\/[^w]*\.google\.com\/*/m';
$str = 'https://ssaa.google.com/
https://google.google.com
https://www.google.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);