re = /^https:\/\/[^w]*\.google\.com\/*/m
str = 'https://ssaa.google.com/
https://google.google.com
https://www.google.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end