package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*\(\d+\)$`)
var str = `hello (2)
hello (22)
hello (22) a
hello (2s)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}