$re = '/\s*\(\d+\)$/m';
$str = 'hello (2)
hello (22)
hello (22) a
hello (2s)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);