$re = '/([+-]? \d+(?:\.\d*)?|\.\d+(?:[eE][+-]?\d+)?) ([a-zA-Z0-9_]+)/';
$str = 'R10666: 273141 C1 + 273141 C2 + 273141e+7 C3 + 273141 C4 + 273141 C5 - 273141 C6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);