re = /([+-]? \d+(?:\.\d*)?|\.\d+(?:[eE][+-]?\d+)?) ([a-zA-Z0-9_]+)/
str = 'R10666: 273141 C1 + 273141 C2 + 273141e+7 C3 + 273141 C4 + 273141 C5 - 273141 C6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end