package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([^:]+):)?constantString:(.*)$`)
var str = `randomString:constantString:somethingElse
constantString:somethingElse`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}