re = /^(?:([^:]+):)?constantString:(.*)$/m
str = 'randomString:constantString:somethingElse
constantString:somethingElse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end