import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\. [a-z1-9\\. ]*?com/)\\. ";
final String string = "Eastern Illinois University is one of only three universities in the United States to run its own newspaper printing press http://www. dailytexanonline. com/top-stories/student-media-board-votes-to-sell-press-1.1309992 and is one of the smallest universities in the country to have a daily newspaper. The paper was renamed Teacher's College News and Eastern State News before its current name was chosen in 1980. http://media. www. dennews. com/media/storage/paper309/news/2005/11/04/News/The-News. Turns.90-1045667. shtml Notable alumni of the newspaper include Wall Street Journal reporter Cam Simpson";
final String subst = ".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}