#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*?\: )(.+?)[\r\n]"
Local $sString = "Name of House: Aasleagh Lodge" & @CRLF & _
"Townland: Srahatloe" & @CRLF & _
"Near: Killary Harbour, Leenane" & @CRLF & _
"Status/Public Access: maintained, private fishing lodge" & @CRLF & _
"Date Built: 1838-1850, burnt 1923, rebuilt 1928**" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")