re = /(.*?\: )(.+?)[\r\n]/
str = 'Name of House: Aasleagh Lodge
Townland: Srahatloe
Near: Killary Harbour, Leenane
Status/Public Access: maintained, private fishing lodge
Date Built: 1838-1850, burnt 1923, rebuilt 1928**
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end