const regex = /\({[^}]*}\)|NULL|\s+(?!\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\({[^}]*}\\)|NULL|\\s+(?!\\w)', 'g')
const str = `NULL ({ / / }) Regina ({ 4 p1 p2 / / }) Shueller ({ 5 p1 p2 / / }) works ({ / / }) for ({ / / }) Italy ({ 14 / / }) 's ({ 15 / / }) La ({ 16 / / }) Repubblica ({ 17 / / }) newspaper ({ 18 / / }) . ({ 38 / / })`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);