$re = '/\({[^}]*}\)|NULL|\s+(?!\w)/';
$str = 'NULL ({ / / }) Regina ({ 4 p1 p2 / / }) Shueller ({ 5 p1 p2 / / }) works ({ / / }) for ({ / / }) Italy ({ 14 / / }) \'s ({ 15 / / }) La ({ 16 / / }) Repubblica ({ 17 / / }) newspaper ({ 18 / / }) . ({ 38 / / })';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;